The Pix platform

Which web browser should I use?


Pix is compatible with most of the internet browsers: Firefox, Chrome, Edge, Internet Explorer, Safari, etc.

We recommend using a recent version of these browsers. This will improve your experience on our platform (and enhance the security of your web browsing in general!).

For Internet Explorer in particular, you should use IE 9 or above.


Modified on: Tue, 16 Feb, 2021 at 12:44 PM

Vous ne trouvez pas la réponse à votre question ? Vous pouvez nous contacter en cliquant ici.